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Laboratorio 1 — Guia del Alumno

Laboratorio 1: Pruebas y depuracion

15-02-2021

Objetivos
1. Desarrollar algoritmos sencillos,
2. Depurar un programa, para detectar y corregir errores:
a. Ejecutar casos de pruebas con JUnit
b. Anadir trazas/registros en el codigo
c. Usar el depurador para detectar y corregir errores

Actividades
Ejercicio 1: Analisis del flujo de ejecucion

El objetivo de este ejercicio es ejecutar los casos de prueba de una clase y entender
como se pueden definir. Para ello, se proporciona un proyecto cuyo componente
principal es la clase WordCounter, en la que se definen varios métodos que permiten
contar el nimero de palabras de un texto y determinar cuales son las n mas (o
menos) utilizadas. La clase incluye un método main con una prueba basica de
funcionamiento (smoke test!). También se proporciona una bateria de pruebas
configurada con JUnit 4, con varios casos de prueba definidos.

<<Java Class>>
(®WordCounter
es.upm.dit.adsw.wc <<Java Class>>
<<Java Class>> @ WordCounter() es?)::g:::c
©Meter3 © resel():vold ) o clave: String
es.upm.dit.adsw.wc @ load(File):void -
57 DIR: String o load(String):void = “ccm‘ mo
S LAZARILLO: String @ put(String):void T @ Registro(String)
SfQUIOTE: String [~ | @ size()int A © getClave():String
5.f SHAKESPEARE: String © getTop(int):.List<Registro> © getCnt():int
FMeter3() = getMyBot(int):List<Registro> © inc():void -
S main(String[])-void = getMyTop(int):List<Registro> @ wmpareTo(Beglstr o)int
e measure(String]]):void m getDatos():vold 0.+ | @ toSting():String
@ countBelow(int):int
@°main(String[]):void
s°dump(String,List<Registro>):void
@ print():void

En el proyecto se incluyan las siguientes clases:
e WordCounter: es la clase que procesa los textos de entrada y genera la salida.
e Registro: es un contenedor para asociar un contador a una palabra.
e WordCounterTest: Bateria de pruebas para WordCounter.
e Meter: Programa para procesar varios ejemplos de ficheros de texto,
calculando su tamafio y el tiempo de ejecucion.
Las actividades que se proponen son:

1 Un smoke test es una prueba elemental de que un programa funciona, sin entrar en detalles ni
casos particulares.
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1. Instalar el proyecto WordCounter.
El proyecto esta disponible en Moodle. Los pasos para instalarlo en Eclipse
se describen en el Anexo 1.
2. Ejecutar el programa
La clase WordCounter incluye un método main para ejecutar una prueba
elemental con un texto breve. La clase Meter realiza el procesamiento de
ficheros de texto mas largos. Los ficheros estan incluidos en el archivo zip en
que se distribuye el proyecto (carpeta libros).
Para ejecutar una clase,
a. Seleccionarla en el explorador de paquetes
b. Con el botén derecho, Run As > Java Application
3. Ejecutar la clase con las pruebas:
a. Seleccionar WordCounterTest en el explorador de paquetes.
b. Run as -> JUnit Test
4. Leer el codigo de las pruebas para conocer su estructura y estudiar como
se ejecuta.

Ejercicio 2: Depuracidon de un programa

En este ejercicio, se proporciona un proyecto que tiene una clase que implementa
una lista doblemente enlazada. La gestion de los elementos es de tipo FIFO: el primer
dato insertado sera el primero en salir. La clase proporciona métodos para poner y
quitar valores enteros de la lista, para conocer el tamafio de la lista y escribir la lista.

La implementacion se basa en guardar los valores en objetos de la clase Celda. Para
mantener la lista, cada celda apunta a la celda anterior y a la siguiente. La lista
contiene dos referencias que apuntan, respectivamente, a la primera y a la tltima
celda.

La lista doblemente enlazada tiene la ventaja de que no ocupa apenas memoria si no
hay objetos en la lista.

En el proyecto se incluyan las siguientes clases (ver la figura del modelo de clases):
e Lista: Interfaz de una lista FIFO acotada.
e (elda: La celda que mantiene un enlace a una celda anterior, un enlace a la
celda siguiente y el valor de la celda.
e ListaDoblementeEnlazada: Lista doblemente enlazada. La lista tiene una
capacidad maxima, y si se llena no se pueden afiadir mas valores.
e Prueba_ListaDoblementeEnlazada: Ejecucion de una lista.
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<<Java Class>>

( ListaDoblementeEnlazada
es.upm.dit.adsw.Lista

o maxValores: int
o nValores: int
o ultimo: Celda

@ ListaDoblementeEnlazada(int)
@ estallena():boolean

@ estaVacia():boolean

® getNValores():int

@ pon(int):void

@ quita():int

@ estaElValor(int):boolean

© toString():String 4

2

<<Java Class>>

G Celda

es.upm.dit.adsw.Lista

o anterior: Celda
o siguiente: Celda
o valor: int

@ Celda()

@ Celda(Celda,Celda,int)
© getAnterior():Celda

© setAnterior(Celda):void
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<<Java Class>>
(G Prueba_ListaDobleEnlazada

es.upm.dit.adsw.Lista

@ Prueba_ListaDobleEnlazada()

@ main(String[]):void

. Vi
Q <<Java Interface>>
O Lista

es.upm.dit.adsw.Lista

@ estallena():boolean

o estaVacia():boolean

© getNValores():int

@ pon(int):void

@ quita():int

@ estaElValor(int):boolean

© getSiguiente():Celda

© setSiguiente(Celda):void
© getValor():int

@ setValor(int):void

@ toString():String

En la siguiente figura se muestra un ejemplo de la ejecucion. Inicialmente, las
referencias primero y tiltimo contienen null. Segiin se ponen o quitan valores, se van
actualizando estas variables. Por ejemplo, al poner un valor cuando la lista esta vacia
hay que actualizarla asi:

e Primeroy ultimo apuntan a la celda nueva.

e Los enlaces de la celda nueva apuntan a null, porque no hay mas celdas

Al afiadir un nuevo valor hay que hacer que:
e El atributo siguiente de la nueva celda apunte a la celda a la que apuntaba
ultimo
e El atributo anterior de la celda que estaba en ultimo lugar (aquella a la que
apuntaba la referencia ultimo de la lista) apunte a la celda nueva.
e Ultimo apunte a la celda nueva

Las operaciones del método quita se comportan de forma analoga.
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Valor

Celda: Anterior

Siguiente

ultimo primero

null null

5
> null [« :I pon(5)
null
8 5
|:’—> null [<— - pon(8)
| null
3 8 5
[ | nuije— — | pon(3)

null

A

gL

quita(): se retorna “5”

\

null

quita(): se retorna “8”

null |«

Y

null

[ ]
l—l quita(): se retorna “3”

null null

El cédigo proporcionado tiene errores. Para poder corregir los problemas se
propone realizar las siguientes actividades:

1. Instalar el proyecto ListaDoblementeEnlazada.
La instalacion se realiza como en el ejercicio anterior.
2. Estudiar bien el funcionamiento de la lista. Si no, sera dificil corregir los
errores
3. Crear una clase de pruebas y generar pruebas.
Las pruebas que se proponen son:
1. Anadir un valor y comprobar que el tamafio de la lista es 1. Luego, quitar
un valor y comprobar que se retorna un 1y que el tamafo es 0.
2. Haga algo similar afiadiendo varios valores, sin llenar la lista, y
comprobar que se retornan bien los datos y el tamafio es correcto.
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3. Afadir valores hasta llenar la lista. Comprobar que no se cambia la lista
cuando se afiada un nuevo valor. Comprobar que los contenidos y el
tamafio de la lista son correctos.

4. Ejecutar un programa de prueba basico.
Se puede tomar como punto de partida el programa Prueba_Lista Doblemente
Enlazada incluido en el proyecto.

5. Aiadir trazas para seguir la ejecucion.

Las trazas (logs) sirven para tener informacion sobre el estado de la lista al

ejecutar un programa.

6. Ejecutar el programa con las trazas.

Observe la salida para detectar los fallos. En caso de que sea necesario, afiada

trazas adicionales.

7. Ejecutar el programa usando el depurador.

Defina puntos de ruptura y ejecute el programa paso a paso, o hasta el

siguiente punto de ruptura, y compruebe si la ejecucidon es correcta.

Ejercicio 3: Desarrollar un algoritmo sencillo

En este ejercicio, se propone desarrollar el siguiente método de la clase
ListaDoblementeEnlazada:

estaElValor

public boolean estaElValor(int Valor)
Comprobar si un valor esta almacenado en la lista

Parameters:

Valor - ELl valor a comprobar

Returns:

True, si el valor estd en la lista

Use las técnicas propuestas en este enunciado para comprobar si el codigo es
correcto.

Anexos:

Anexo 1: Cargar un proyecto en Eclipse

e Seleccione el mendu File > Import > Existing Projects into Workspace > Next

e Navegue hasta el archivo zip que contiene el proyecto tal como se ha bajado de
Moodle.

e Compruebe que el proyecto esta marcado, y seleccione Finish

Anexo 2: Generar y acceder a la documentacion con Javadoc en Eclipse
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La documentacion existente se encuentra en la carpeta doc del proyecto. Para
consultarla, abra el fichero index.html en un navegador (botén derecho > Open with
> Web browser).

También puede consultar la documentacidon desde una ventana del editor de
cddigo Java. Si posiciona el raton sobre el nombre de una clase o un método
aparece una ventana auxiliar con un resumen de la documentacion.

Si tiene activada la vista Javadoc (con Window > Show View > Javadoc), al hacer clic
sobre el nombre de un elemento se mostrara la documentacidn correspondiente
en la ventana correspondiente a esta vista.

Para generar o actualizar la documentacioén javadoc vaya al menu Project >
Generate Javadoc. Si aparecen errores de codificacidon de caracteres asegurese de
poner las opciones -encoding utf8 -docencoding utf8 -charset utf8 enel
cuadro VM options de la tercera ventana que aparece (después de hacer Next dos
veces).

Anexo 3: Crear una clase de JUnit

Situese sobre la ventana del editor correspondiente a la clase que quiere probar y
vaya al menu File > New > Junit Test Case. Asegurese de que esta seleccionada la
opcion “New Junit 4 test”, y conteste afirmativamente si el entorno le pide afiadir la
biblioteca Junit 4 al proyecto.

Anexo 4: Configurar el registrador (logger) java.util.logging

Los pasos basicos para configurar y usar en un programa son:
1. Importar el paquete

|import java.util.logging.*,

2. Crear el configurador, que debe ser un atributo de la clase:

static final Logger LOGGER =
Logger.getlLogger(ListaTrazas.class.getName());

3. Configurar el registrador. Ejecutar las siguientes instrucciones en el
constructor en el que se van a poner los registros:

LOGGER.setUseParentHandlers(false);
handler = new ConsoleHandler();
handler.setLevel(Level.FINEST);
LOGGER.addHandler (handler);
LOGGER.setLevel(Level .FINEST);
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4. Incluir las trazas donde se considere:

LOGGER.info("Comentario");

LOGGER.fine("La lista: " + toString()),;

Anexo 5: Uso del depurador

El depurador permite identificar y eliminar errores de un programa que compila y
ejecuta pero que no produce resultados correctos. El depurador ejecuta el programa
de forma interactiva, permitiendo observar una a una las instrucciones que se
ejecutaran, las variables activas en memoria y sus valores. Para iniciar el depurador
sobre la clase que contiene el método main marque -Menu: Run->Debug

Las herramientas disponibles para el control de la ejecucién son varias:
e Puntos de parada “breakpoints”. Paran la ejecucién del programa en
instrucciones determinadas.
e Perspectiva de depuracion con las siguientes vistas:
o0 Vista de visualizacién y modificacion de valores de variables.
0 Vista de consola que muestra la salida del programa
———@- Vista de editor del codigo fuente con una linea verde en la
instruccién que va a ser ejecutada
—e- Vista de depuracidn indicando la linea de c6digo que va a ser
ejecutada
o Vista de vigilancia de expresiones

[Tatner: ~ | 2@ |5 i 0 ri® S 5 . u;ch l Ji| &5 &ueve [Apobug

¥ = B - Variables 82 Breakpoi Expressions B8 v=0

Name Value
at © args String[0] (id=15)

©op peracionesReales (id=18)
known declaring type>> © uno 21
8.0.25) (201112015 12:52:48)

ava Applica

(201112015 15:52:47)

= Sow v
[3) PruebaOperacionesjava 52 111 OperacionesC: jos.jav B 2= outine R SRR NI a

118

i 19 // Pruebas de operaciones con reales "o S mainttingD s void
1220 System.out.println("___PRUEBAS DE OPERACIONES CON REALES___":

=21 OperacionesReales op = new OperacionesReales();

{22 double uno = 2.1;

1223 double dos = 3.2;

|24 double suma = op.sumaCuno, dos);

|25 double multiplicacion = op.multiplicacionCuno, dos);

| = e e [
+ & onsole | ZlTasks Ju Junit XEEE ¥B-00-= 0

8.0.25. (20/1/2015 15:52:47)

Wava lication] /L
| PRUEBAS DE OPERACIONES CON REALES

|
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e Control de la ejecucion paso a paso, entrando en los métodos (Step in) o
ejecutando los métodos completos y parando al terminar de ejecutarlos
(Step over).

Para buscar un error en un programa pondremos un punto de parada en la primera
sentencia ejecutable del método main. Iremos ejecutando controladamente el
cddigo entrando en los métodos suma y multiplicacion de la clase Operaciones
reales saltando las instrucciones que ejecutan constructores o llamadas a métodos
de clases de la API de Java.

Se observa que las variables op, uno y dos sélo aparecen en la vista de variables en
memoria tras su declaracion. Al entrar en la ejecucion del método suma se modifican
varias vistas. En la del editor se ve la clase OperacionesReales. En la vista de variables
se observan las variables disponibles por el método suma: la referencia a la propia
instancia, this, y los parametros dos y uno. Estas variables contienen los valores
pasados al invocar el método. Aunque las variables tienen los mismos nombres que
en la sentencia que invoca al método, estan cambiadas de orden de modo que la
variable dos contiene el valor almacenado en la variable uno de main. Se puede
seguir ejecutando y salir del método. Se puede ver que los valores de las variables
uno y dos no han cambiado.

Interrupcion de la Ejecucion de la
ejecucion siguiente sentencia
\ sin entrar en métodos
Ejecucion hasta /
Siguiente breakpoint > 0> f ~ |

Ejecucion de la
siguiente sentencia
entrando en métodos

Respecto al ejercicio 2, utilice el depurador para ver qué ocurre y verificar si se ha
producido o no el intercambio de valores deseado. Para ello se pone otro punto de
parada en la sentencia que imprime el mensaje de cambio de seccion. Al ejecutar el
programa en modo debug, éste se parara en el primer punto de parada. Siga la
ejecucion hasta al siguiente punto de parada para ya ir instruccion a instruccion.
Continue con la depuracidn hasta entender por qué un método funciona y otro no.

En la tercera seccion del programa se ejecuta la suma y multiplicacion de dos
numeros complejos. El programa funciona sin problemas, pero no da el valor
adecuado. Debe identificar y corregir los errores usando el depurador.



